avatar

算法-模拟队列

模拟队列

实现一个队列,队列初始为空,支持四种操作:

(1) “push x” – 向队尾插入一个数x;

(2) “pop” – 从队头弹出一个数;

(3) “empty” – 判断队列是否为空;

(4) “query” – 查询队头元素。

现在要对队列进行M个操作,其中的每个操作3和操作4都要输出相应的结果。

输入格式

第一行包含整数M,表示操作次数。

接下来M行,每行包含一个操作命令,操作命令为”push x”,”pop”,”empty”,”query”中的一种。

输出格式

对于每个”empty”和”query”操作都要输出一个查询结果,每个结果占一行。

其中,”empty”操作的查询结果为“YES”或“NO”,”query”操作的查询结果为一个整数,表示队头元素的值。

数据范围

1≤M≤1000001≤M≤100000,
1≤x≤1091≤x≤109,
所有操作保证合法。

输入样例:

10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6

输出样例:

NO
6
YES
4

题解:

#include <iostream>
#include <queue>
#include <string>
using namespace std;
int main()
{
    queue<int> a;
    int m;
    cin >> m;
    while (m--)
    {
        int x;
        string s;
        cin >> s;
        if( s == "push")
        {
            cin >> x;
            a.push(x);
        }
        else if( s == "pop") a.pop();
        else if( s == "empty")
        {
            if(a.empty()) cout << "YES" << endl;
            else cout << "NO" << endl;

        }

        else if( s == "query") cout << a.front() << endl;
    }
    return 0;
}
文章作者: wangzun233
文章链接: https://wangzun233.top/2020/04/12/%E7%AE%97%E6%B3%95-%E6%A8%A1%E6%8B%9F%E9%98%9F%E5%88%97/
版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明来自 WangZun233